package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("[^"]*"),"[^"]*","[^"]*"(,"[^"]*")`)
var str = `"1234","1234","S243","Text"
"1234","1234","01A243","other Text"`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}