// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)("[^"]*"),"[^"]*","[^"]*"(,"[^"]*")"#).unwrap();
let string = "\"1234\",\"1234\",\"S243\",\"Text\"
\"1234\",\"1234\",\"01A243\",\"other Text\"";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}