// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)%(?'flag'[-0+ #]{0,3})(?'minwidth'[0-9]*)(?'comma'\.)?(?'precision'(?('comma')[0-9]*))(?'length'[hlqLjzZt]|ll|hh)?(?'type'[dscuobS%nfeEgGaACDiIOUpXx]{1})").unwrap();
  let string = "Hello World! My name is %s and I have %+05.3f€";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}