import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\\+)[0-9]{2}:[0-9]{2}|)\\[(\\w+\\/*\\w*)]";
final String string = "2015-08-30T16:00[America/Phoenix]\n"
+ "2015-08-30T16:00[America]\n"
+ "2015-08-30T16:00-07:00[America/Phoenix]\n"
+ "2015-08-30T16:00+07:00[America/Phoenix]\n"
+ "2015-08-30T16:00-07:00[America]\n"
+ "2015-08-30T16:00+07:00[America]\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}