use strict;
my $str = '2015-08-30T16:00[America/Phoenix]
2015-08-30T16:00[America]
2015-08-30T16:00-07:00[America/Phoenix]
2015-08-30T16:00+07:00[America/Phoenix]
2015-08-30T16:00-07:00[America]
2015-08-30T16:00+07:00[America]
';
my $regex = qr/(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\+)[0-9]{2}:[0-9]{2}|)\[(\w+\/*\w*)]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}