import Foundation
let pattern = #"(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\+)[0-9]{2}:[0-9]{2}|)\[(\w+\/*\w*)]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2015-08-30T16:00[America/Phoenix]
2015-08-30T16:00[America]
2015-08-30T16:00-07:00[America/Phoenix]
2015-08-30T16:00+07:00[America/Phoenix]
2015-08-30T16:00-07:00[America]
2015-08-30T16:00+07:00[America]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)