package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(href=")(\/[^"]*?\/)([^\/]*\.[^"]+)`)
var str = `<a href="/app/webroot/files/file/Edital%20143-2011.pdf">
<a target="_blank" href="http://www.ipea.gov.br/code/chamada2011">
`
var substitution = "\1/sites/default/files/resources/\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}