use strict;
my $str = '<a href="/app/webroot/files/file/Edital%20143-2011.pdf">
<a target="_blank" href="http://www.ipea.gov.br/code/chamada2011">
';
my $regex = qr/(href=")(\/[^"]*?\/)([^\/]*\.[^"]+)/p;
my $subst = '\\1/sites/default/files/resources/\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";