package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)'[\w|\s]*([']*)[\w|\s]*'`)
var str = `'sinead o'connor','don't don't','whatever', 'sas1'23'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}