$re = '/\'[\w|\s]*([\']*)[\w|\s]*\'/mi';
$str = '\'sinead o\'connor\',\'don\'t don\'t\',\'whatever\', \'sas1\'23\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);