const regex = /^(?<latitude>[-]?[0-8]?[0-9]\.\d+|[-]?90\.0+?)(?<delimeter>.)(?<longitude>[-]?1[0-7][0-9]\.\d+|[-]?[0-9]?[0-9]\.\d+|[-]?180\.0+?)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<latitude>[-]?[0-8]?[0-9]\\.\\d+|[-]?90\\.0+?)(?<delimeter>.)(?<longitude>[-]?1[0-7][0-9]\\.\\d+|[-]?[0-9]?[0-9]\\.\\d+|[-]?180\\.0+?)$', '')
const str = `-12.213213;-1.21321`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}