const regex = /^([\s\S]{1,200})[\s]+?[\s\S]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\s\\S]{1,200})[\\s]+?[\\s\\S]+', 'g')
const str = `I have a code snippet written in PHP that pulls a block of text from a database and sends it out to a widget on a webpage. The original block of text can be a lengthy article or a short sentence orrrr two; but for this widget I can't display more than, say, 200 characters. I could use substr() to chop off the text at 200 chars, but the result would be cutting off in the middle of words-- what I really want is to chop the text at the end of the last word before 200 chars.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);