$re = '/^(b\1|^a)+$/m';
$str = 'a
aba
ababba
ababbabbba
ababbabbbabbbba
ababbabbbabbbbabbbbba
abba
abbba
aa
abbaa
aabb
abababa
ababbba
abbaba
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);