#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*((?:const\s+|virtual\s+|friend\s+|volatile\s+){0,4}\s*?(?:\w+\s*::)?\s*[\w]+)\s+(\w+)\s*\([\s\S]*?\)\s*(const)?\s*{"
Local $sString = "#include "Port.h"" & @CRLF & _
"" & @CRLF & _
"namespace Port {" & @CRLF & _
"" & @CRLF & _
" uint8_t lirePin(volatile uint8_t * pin)" & @CRLF & _
" {" & @CRLF & _
" return * pin;" & @CRLF & _
" }" & @CRLF & _
" /*********************************************************************" & @CRLF & _
" * retourne vrai si les pin du port pin sont ouvert" & @CRLF & _
" * pin = PINA a PIND" & @CRLF & _
" *********************************************************************/" & @CRLF & _
" bool lirePin(uint8_t pins, volatile uint8_t * pin)" & @CRLF & _
" {" & @CRLF & _
" return (*pin & pins);" & @CRLF & _
" }" & @CRLF & _
" /*********************************************************************" & @CRLF & _
" * Met la pin du port port a 5V" & @CRLF & _
" * port = PORTA a PORTD" & @CRLF & _
" *********************************************************************/" & @CRLF & _
" void ouvrirPin(uint8_t pins, volatile uint8_t * port)" & @CRLF & _
" {" & @CRLF & _
" *port |= pins;" & @CRLF & _
" }" & @CRLF & _
" /*********************************************************************" & @CRLF & _
" * Met la pin du port port a 0V" & @CRLF & _
" * port = PORTA a PORTD" & @CRLF & _
" *********************************************************************/" & @CRLF & _
" void fermerPin(uint8_t pins, volatile uint8_t * port)" & @CRLF & _
" {" & @CRLF & _
" *port &= ~pins;" & @CRLF & _
" }" & @CRLF & _
" /*********************************************************************" & @CRLF & _
" * Met la pin du port ddr en Entree" & @CRLF & _
" * ddr = DDRA a DDRD" & @CRLF & _
" *********************************************************************/" & @CRLF & _
" void pinEntree(uint8_t pins, volatile uint8_t * ddr)" & @CRLF & _
" {" & @CRLF & _
" *ddr &= ~pins;" & @CRLF & _
" }" & @CRLF & _
" /*********************************************************************" & @CRLF & _
" * Met la pin du port ddr en Sortie" & @CRLF & _
" * ddr = DDRA a DDRD" & @CRLF & _
" *********************************************************************/" & @CRLF & _
" const volatile friend std::void pinSortie(uint8_t pins, " & @CRLF & _
"volatile uint8_t * ddr)" & @CRLF & _
" {" & @CRLF & _
" *ddr |= pins;" & @CRLF & _
" }" & @CRLF & _
" /*********************************************************************" & @CRLF & _
" * Met le port ddr en Entree" & @CRLF & _
" * ddr = DDRA a DDRD" & @CRLF & _
" *********************************************************************/" & @CRLF & _
" void portEntree(volatile uint8_t * ddr) const" & @CRLF & _
" {" & @CRLF & _
" *ddr = ENTREE;" & @CRLF & _
" }" & @CRLF & _
" /*********************************************************************" & @CRLF & _
" * Met le port ddr en Entree" & @CRLF & _
" * ddr = DDRA a DDRD" & @CRLF & _
" *********************************************************************/" & @CRLF & _
" void portSortie(volatile uint8_t * ddr)" & @CRLF & _
" {" & @CRLF & _
" *ddr = SORTIE;" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")