import Foundation
let pattern = #"^\s*((?:const\s+|virtual\s+|friend\s+|volatile\s+){0,4}\s*?(?:\w+\s*::)?\s*[\w]+)\s+(\w+)\s*\([\s\S]*?\)\s*(const)?\s*{"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#include "Port.h"
namespace Port {
uint8_t lirePin(volatile uint8_t * pin)
{
return * pin;
}
/*********************************************************************
* retourne vrai si les pin du port pin sont ouvert
* pin = PINA a PIND
*********************************************************************/
bool lirePin(uint8_t pins, volatile uint8_t * pin)
{
return (*pin & pins);
}
/*********************************************************************
* Met la pin du port port a 5V
* port = PORTA a PORTD
*********************************************************************/
void ouvrirPin(uint8_t pins, volatile uint8_t * port)
{
*port |= pins;
}
/*********************************************************************
* Met la pin du port port a 0V
* port = PORTA a PORTD
*********************************************************************/
void fermerPin(uint8_t pins, volatile uint8_t * port)
{
*port &= ~pins;
}
/*********************************************************************
* Met la pin du port ddr en Entree
* ddr = DDRA a DDRD
*********************************************************************/
void pinEntree(uint8_t pins, volatile uint8_t * ddr)
{
*ddr &= ~pins;
}
/*********************************************************************
* Met la pin du port ddr en Sortie
* ddr = DDRA a DDRD
*********************************************************************/
const volatile friend std::void pinSortie(uint8_t pins,
volatile uint8_t * ddr)
{
*ddr |= pins;
}
/*********************************************************************
* Met le port ddr en Entree
* ddr = DDRA a DDRD
*********************************************************************/
void portEntree(volatile uint8_t * ddr) const
{
*ddr = ENTREE;
}
/*********************************************************************
* Met le port ddr en Entree
* ddr = DDRA a DDRD
*********************************************************************/
void portSortie(volatile uint8_t * ddr)
{
*ddr = SORTIE;
}
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)