package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z][a-z]+|[0-9]+)`)
var str = `WordWord999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}