// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z]+|[!@#$%^&*()_=;.?])[0-9]+").unwrap();
let string = "jkl3242oij92384nji332332!23#900&6382^832983@7729.979797_70979797";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}