$re = '/^(?:2[0-5][0-5]|1?[1-9]\d?|0)\.(?:2[0-5][0-5]|1?[1-9]\d?|0)\.(?:2[0-5][0-5]|1?[1-9]\d?|0)\.(?:2[0-5][0-5]|1?[1-9]\d?|0)$/';
$str = '123.123.123.123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);