package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)span>.*?(game).*?<\/span`)
var str = `<div class="fsearchp">
<p><a href="/5278-bams-bad-ass-game-show.html" title="Пе рейти на страницу сериала «Bam's Bad Ass Game Show»">Bam's Bad Ass Game Show</a> (2014 - ...)
<span>(Bam's Bad Ass Game Show)</span>
</p>
</div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}