# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"span>.*?(game).*?<\/span"
test_str = ("<div class=\"fsearchp\">\n"
"<p><a href=\"/5278-bams-bad-ass-game-show.html\" title=\"Перейти на страницу сериала «Bam's Bad Ass Game Show»\">Bam's Bad Ass Game Show</a> (2014 - ...)\n"
"<span>(Bam's Bad Ass Game Show)</span> \n"
"</p> \n"
"</div>")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.