package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*-11-03-2015-.*_470123023_META\.xml`)
var str = `wehansen-11-03-2015-09-35-12_470123023_META.xml`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}