import Foundation
let pattern = #".*-11-03-2015-.*_470123023_META\.xml"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"wehansen-11-03-2015-09-35-12_470123023_META.xml"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}