#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^abc$|i10n"
Local $sString = "abc" & @CRLF & _
"i10n " & @CRLF & _
"10abc" & @CRLF & _
"abcабвгд " & @CRLF & _
"abc.3 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")