package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^abc$|i10n`)
var str = `abc
i10n
10abc
abcабвгд
abc.3 `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}