#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ":(?=:|$)"
Local $sString = "1050:::600:5:1000::"
Local $sSubst = ":0000"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)