use strict;
my $str = '1050:::600:5:1000::';
my $regex = qr/:(?=:|$)/p;
my $subst = ':0000';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";