# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!--# include (\bvirtual\b|\bfile\b)=(\"|')(.+)(\"|').*-->"
test_str = ("{% ssi /home/django/cmsenv/cmsintegration/cms_pages/templates/test.html parsed %}\n\n\n"
"<!--# include file=\"/site_media/test2.js\"-->\n"
"<!--# include file=\"/site_media/test.js\"-->\n"
"<!--# include file='/site_media/media/test.js'-->\n\n"
"<!--# include virtual=\"/shop/getstates/1\"-->\n"
"<!--# include virtual=\"/css\"-->\n\n\n"
"<!--# include file='/site_media/test2.js'-->\n"
"<!--# include file='/site_media/test.js'-->\n"
"<!--# include file=\"/site_media/media/test.js\"-->\n\n\n\n"
" {# EXTRA_CSS #}\n"
" {% if website.var.obj.extra_css %}\n"
" <style type=\"text/css\">\n"
" {{ website.var.obj.extra_css|safe }}\n"
" </style>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.