#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"[^"]?"""
Local $sString = "1 "many word " "many word" "many word "" & @CRLF & _
"2 "many word " " <-Error quotation" & @CRLF & _
"3 "many word " "many word " " many word " " many word " " <-Error quotation" & @CRLF & _
"4 """ but this quotation not match" & @CRLF & _
"5 "\"" this is not match" & @CRLF & _
"6 " aasd \" " " <-Error quotation \"" & @CRLF & _
"" & @CRLF & _
"only line 2 3 6 have an error quotation i need to find a line have an error quotation by regex"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")