// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"]?"""#).unwrap();
let string = "1 \"many word \" \"many word\" \"many word \"
2 \"many word \" \" <-Error quotation
3 \"many word \" \"many word \" \" many word \" \" many word \" \" <-Error quotation
4 \"\"\" but this quotation not match
5 \"\\\"\" this is not match
6 \" aasd \\\" \" \" <-Error quotation \\\"
only line 2 3 6 have an error quotation i need to find a line have an error quotation by regex";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}