const regex = /\b(?!(?:[+-]?\d*\.?\d+(?:e[+-]?\d+)?|log|sin|cos)\b)\w+\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(?:[+-]?\\d*\\.?\\d+(?:e[+-]?\\d+)?|log|sin|cos)\\b)\\w+\\b', 'gi')
const str = `(var1 * 1.3e4 + abc)/log(blabla+2E3)
1.2E+23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}