import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?):(.*?),'(.*?)',(.*?),(.*?),(.*?)$";
final String string = "COOP:166657,'NEW IBERIA AIRPORT ACADIANA REGIONAL LA US',200001,177,553\n"
+ "COOP:166884,'NEW LONDON AIRPORT ACADIANA REGIONAL LA US',200001,177,888";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}