re = /^(.*?):(.*?),'(.*?)',(.*?),(.*?),(.*?)$/m
str = 'COOP:166657,\'NEW IBERIA AIRPORT ACADIANA REGIONAL LA US\',200001,177,553
COOP:166884,\'NEW LONDON AIRPORT ACADIANA REGIONAL LA US\',200001,177,888'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end