// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?):(.*?),'(.*?)',(.*?),(.*?),(.*?)$").unwrap();
let string = "COOP:166657,'NEW IBERIA AIRPORT ACADIANA REGIONAL LA US',200001,177,553
COOP:166884,'NEW LONDON AIRPORT ACADIANA REGIONAL LA US',200001,177,888";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}