$re = '/^(?:[A-Za-z0-9_][A-Za-z0-9_\-]*(?:\.[A-Za-z0-9_\-]+)*\/)+$/';
$str = 'dir
dir/
dir//
dir./
-dir/
.dir/
_dir/
__dir/
_-dir/
_.dir/
dir.name/
ABCDEFGHIJKLMNOPQRSTUVWXYZ.abcdefghijklmnopqrstuvwxyz.0123456789_-/
dir/dir/filename
dir/dir/filename.ext
// values currently used in wjec.services.properties:
dev.est.edientries.archive
dev-est-reports
dev-est-csv-import
dev-est-csv-import-archive
// alternatives:
dev.est.edientries.archive/
dev-est-reports/
dev-est-csv-import/
dev-est-csv-import-archive/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);