using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(AB(?:[0-9A-Z]{5}|[0-9]{4}))(?:\s+)";
string input = @"foo
AB0001
AB0002 foo
foo AB0003
foo AB0004A AB0004.1
AB0005.1 foo AB0005A bar AB0005";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}