use strict;
my $str = '@line 1: text text text
line 2:
@line3: text text text
line 4: The line break after this text should be matched
line 5: The line break after this text also should be selected
line 6:
@line 7: this line break should not be selected
';
my $regex = qr/^[^@].*(\n?\r?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}