package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4,5}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01]))$`)
var str = `2022-01-01
2022-12-31
2022-1-1
2021-10-27
2022-12-31`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}