$re = '/__t\(\s?["\'](.*)["\']\s?\)/i';
$str = 'alert(__t( \'Mingi tekst\' ) );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t(\'Mingi tekst\')
function name() {
console.log(__t(\'sdfsdf\'));
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);