#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)( # Group 1" & @CRLF & _
" \( # Opening bracket" & @CRLF & _
" ( # Group 2" & @CRLF & _
" (?: # Non-capturing group" & @CRLF & _
" [^()] # Match anything except opening or closing parentheses" & @CRLF & _
" | # Or" & @CRLF & _
" (?1) # Repeat Group 1" & @CRLF & _
" )* # Repeat the non-capturing group zero or more times" & @CRLF & _
" ) # End of group 2" & @CRLF & _
" \) # Closing bracket" & @CRLF & _
")"
Local $sString = "(user email ends with "@email.com" and user name is "John") or ((user email ends with "@domain.com" and user name is "Bob") or (user id is 5))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")