package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`&(.*?)=(?:\$(\w+){)?([^&\z}]*)`)
var str = `ResolvePublishAlarmInfoAck#tibco.AG.XML?RESOLVEPUBLISHALARMINFOACK_XML:=$PARAM{RESPONSE_MESSAGE}
&ERRORCODE=$PARAM{ACK_ERRORCODE}&TOTALTIME=$PARAM{ACK_TOTALTIME}&OVERHEADTIME=$PARAM{ACK_OVERHEADTIME}&SRCSYSTEM=RESOLVE&REQUESTID=$PARAM{REQUESTID}&SRCALARMID=$PARAM{ACK_ALARMID_SRCALARMID}&ERRORLIST=$PARAM{ACK_ERRORLIST}&USERMESSAGE=$PARAM{ACK_USERMESSAGE}&ERRORMESSAGE=$PARAM{ACK_ERRORMESSAGE}&SEVERITYLEVEL=$PARAM{ACK_SEVERITYLEVEL}&HOSTERRORLISTID=$PARAM{ACK_HOSTERRORLISTID}&TRANSACTIONSTATUS=$PARAM{ACK_TRANSACTIONSTATUS}&SRCSERVERNAME=$PARAM{ACK_ALARMID_SRCSERVERNAME}&COMPLETEDTIMESTAMP=CURTIME`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}