import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "&(.*?)=(?:\\$(\\w+)\\{)?([^&\\z\\}]*)";
final String string = "ResolvePublishAlarmInfoAck#tibco.AG.XML?RESOLVEPUBLISHALARMINFOACK_XML:=$PARAM{RESPONSE_MESSAGE}\n"
+ "&ERRORCODE=$PARAM{ACK_ERRORCODE}&TOTALTIME=$PARAM{ACK_TOTALTIME}&OVERHEADTIME=$PARAM{ACK_OVERHEADTIME}&SRCSYSTEM=RESOLVE&REQUESTID=$PARAM{REQUESTID}&SRCALARMID=$PARAM{ACK_ALARMID_SRCALARMID}&ERRORLIST=$PARAM{ACK_ERRORLIST}&USERMESSAGE=$PARAM{ACK_USERMESSAGE}&ERRORMESSAGE=$PARAM{ACK_ERRORMESSAGE}&SEVERITYLEVEL=$PARAM{ACK_SEVERITYLEVEL}&HOSTERRORLISTID=$PARAM{ACK_HOSTERRORLISTID}&TRANSACTIONSTATUS=$PARAM{ACK_TRANSACTIONSTATUS}&SRCSERVERNAME=$PARAM{ACK_ALARMID_SRCSERVERNAME}&COMPLETEDTIMESTAMP=CURTIME";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}