package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[^:]|\s+)(\/\/.*)`)
var str = `function(){
//comment
var i = 0; // assignment
http://shittyundetectedurl.com
} // comment`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}