const regex = new RegExp('^\\s*|\\s$|\\s+(?=\\s)', 'gim')
const str = ` this is a sentence `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);