use strict;
my $str = ' this is a sentence ';
my $regex = qr~^\s*|\s$|\s+(?=\s)~imp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";