# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:(?:https?|ftp):\/{2})(?:(?:[0-9a-z_@-]+\.)+(?:[0-9a-z]){2,4})?(?:(?:\/(?:[~0-9a-z\#\+\%\@\.\/_-]+))?\/)*(?=\s|\"))(\/)?(index\.html?)?"
test_str = ("there is some text with <a href=\" http://www.Something.com/ \"> but without index.html; then there is another one that is <a href = \"https://www.other.com/more/stuff/index.html\"> which should be unaltered.\n"
"Finally does it work for href = \"http://www.com/stuff/\"\n"
"http://www.index.com/\n"
"http://ex.com/a/b/\"\n\n"
"http://www.example.com add /index.html\n"
"http://www.example.com/something do nothing\n"
"http://www.example.com/something/ add /index.html \n"
"http://www.example.com/something/index.html do nothing\n")
subst = "\\1/index.html"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.