use strict;
my $str = '<select id="OptionToChoose">
<option value="" selected="selected">Choose option</option>
<option></option>
<option value="1" class="1">Sun</option>
<option class="2" value="2">Earth</option>
<option class="3" selected="selected" value="3" color="blue">Moon</option>
</select>';
my $regex = qr/(?is)(?:<option)([^>]*)( value="[^"]*")([^>]*\>|\>)([^>]*)(?:<)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}