#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<scheme>https?|s?ftp|wss?|git):\/\/(?<subDomain>[a-z0-9-]{1,63}\.(?:[a-z0-9-]{1,63}\.)*)?(?<domain>[a-z0-9-]{1,256})[.](?<tld>[a-z0-9]+)(?::(?<port>[0-9]{1,5}))?(?<path>\/.*/?)?"
Local $sString = "https://www.google.com" & @CRLF & _
"https://google.com:65535" & @CRLF & _
"https://www.google.com/search" & @CRLF & _
"https://google.com/search" & @CRLF & _
"https://www.google.com/" & @CRLF & _
"https://google.com/" & @CRLF & _
"" & @CRLF & _
"http://www.google.com" & @CRLF & _
"http://google.com" & @CRLF & _
"http://www.google.com/search" & @CRLF & _
"http://google.com/search" & @CRLF & _
"http://www.google.com/" & @CRLF & _
"" & @CRLF & _
"http://google.com/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sftp://" & @CRLF & _
"ftp://" & @CRLF & _
"ws://" & @CRLF & _
"wss://" & @CRLF & _
"git://" & @CRLF & _
"git://" & @CRLF & _
"" & @CRLF & _
"https://my.website-is.cool.name:5673/thing?456%20asd#foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")