const regex = /(".*)(,)(\s.*")/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(".*)(,)(\\s.*")', 'gi')
const str = `peter@pan.com, lucky <jack@pot.com>, "William Tell" <billy@tell.com>, "John Rambo, III" <johnny@rambo.com>, "there, might, be, several, commas inside the quotes" <multiple@commas.com>,
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>
`;
const subst = `$1<!>$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);