use strict;
my $str = '273385 14093 1522520 1759 277697 283096 1133193 191835 246752 204984 973590';
my $regex = qr/\d+/mp;
my $subst = 'm#$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";