#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+(?:\?(?:\([\da-z]+\))?|[A-Z]+) ?)+$"
Local $sString = "3A 1?(1) 2?(2) 3?(a) 4?(4) 5?(a) 6?(ii) 7?" & @CRLF & _
"4 6?(1) 7?(2) 8?(a) 9?(4) 10?(a) 11?(ii) 12? "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")